Problema extruyendo una cuadrado hacia dentro y turboSmooth

Hola amigos, a ver si alguno me puede ayudar porque me estoy volviendo loco con una tontería pero no doy con la solución. Estoy modelando sobre un cilindro y he cortado una cara y la he extruído en negativo hacia adentro. Cuando aplico el turbosmooth, me hace el agujero redondo. Bueno, pues no soy capaz de dejarlo cuadrado sin perder la forma del cilindro. He probado con chamfer interior, exterior, inlets, smoothing groups etc, y nada, no consigo nada decente. Os pongo unas capturas a ver si me entendéis mejor y me podéis guiar porque ahora mismo estoy muy bloqueado y frustrado.

Aquí el agujero normal recién extruido:

Problema extruyendo una cuadrado hacia dentro y turboSmooth-sin-titulo.jpg

Aquí con el turbosmooth (Hasta aquí todo normal).

Problema extruyendo una cuadrado hacia dentro y turboSmooth-sin-titulo2.jpg

Bueno, pongo un chamfer en el borde y turbosmooth (desastre total).

Problema extruyendo una cuadrado hacia dentro y turboSmooth-sin-titulo3.jpg

Bueno, y así con todas las opciones. Simplemente lo que quiero es mantener ese agujero cuadrado sin más, pero no doy con la tecla. El problema es que el modelo es complicado y tiene una cantidad ingente de extrusiones como esta, así que voy arreglado como no encuentre la forma de hacerlo.

Un saludo y gracias a todos.

Miniaturas adjuntas
Problema extruyendo una cuadrado hacia dentro y turboSmooth-sin-titulo.jpg   Problema extruyendo una cuadrado hacia dentro y turboSmooth-sin-titulo2.jpg   Problema extruyendo una cuadrado hacia dentro y turboSmooth-sin-titulo3.jpg