[Blender] Cómo compilar Blender 2 5 en Ubuntu para determinar errores

  • #1
    rubenelpran está desconectado

    Usuario Senior Avatar de rubenelpran


    Como compilar blender 2-5 beta en ubuntu para determinar errores

    Buenas, me pasa lo siguiente resulta que mi Blender 2.5, aquí en Ubuntu me va mal vale, he incluso es como si estuviera incompleto muchas opciones no se ven, no sé qué pasa, tengo un procesador Celeron 580 de Ram, sin tarjeta gráfica, este Blender 2.5 me corría en Windows XP, claro un poco lento, pero podía hacer render y sub, divisiones de superficies, saludos comvives.

    Miniaturas adjuntas Miniaturas adjuntas

    -blender2.png
     

    Última edición por 3dpoder; 28-11-2011 a las 14:17 Razón: Adjuntar las imágenes al foro


  • #2
    rubenelpran está desconectado

    Usuario Senior Avatar de rubenelpran


    Como compilar blender 2 5 en ubuntu para determinar errores

    Por fa no me pueden ayudar, lo necesito y en este foro hay mucho nivel, denme una mano.


  • #3
    renderiche está desconectado

    Entre la bici y el 3D… Avatar de renderiche


    Como compilar blender 2 5 en ubuntu para determinar errores

    Bueno, no tienes que hacer nada en especial, descarga la versión que gustes, la oficial o alguna de graphicall, descomprimes la carpeta y a correr.


  • #4
    rubenelpran está desconectado

    Usuario Senior Avatar de rubenelpran


    Como compilar blender 2 5 en ubuntu para determinar errores

    Ok ok muchas gracias, por la atención, pero es que, ve, desde hace tiempo me da error y se veía mal como en el primer enlace que tengo.

    -blender2.png
    Y ahora intente hacer la compilación que muchos recomiendan aquí y en otros foros, y me da este error al abrir el Blender 2.5 en Xubuntu.

    Claro primero hice la compilación con lo que recomiendan https://www.niel3d.com/niel2/modules/…=2720&forum=27.

    Código:

    Rubn@Rubn-xbuntu:~/blender-svn/install/linux2$./blender. Found bundled Python: /home/Rubn/blender-svn/install/linux2/2.54/Python. Fallo de segmentación

    .

    Última edición por 3dpoder; 28-11-2011 a las 14:21 Razón: Adjuntar las imágenes al foro


  • #5
    angelsan está desconectado

    blenderniaco Avatar de angelsan


    Como compilar blender 2 5 en ubuntu para determinar errores

    Prueba con esto:
    -Descárgate una versión ya compilada que se ajuste a las características de tu equipo aquí.
    -Descomprime el archivo y ejecuta desde un terminal (abres un terminal en la carpeta dónde está el ejecutable y lo lanzas./blender).
    -Observa en el terminal los mensajes de error que te dé. Luego, vuelve a publicar el error en el foro.

    Lo más probable es que sea un problema de dependencias o que te falte alguna (s) librería (s). Con el mensaje de error puedes averiguar que librerías te faltan e instalarlas manualmente desde synaptic. Saludos.


  • #6
    rhinote está desconectado

    Abajofirmante Avatar de rhinote


    Como compilar blender 2 5 en ubuntu para determinar errores

    No sé si los tiros pueden ir por ahí, pero, que versión de Python tienes instalada? (para la 2.5 necesitas Python 2.6).

    Para verlo rápidamente sólo introduce.

    Python.

    Y luego sales con Control +.


  • #7
    rubenelpran está desconectado

    Usuario Senior Avatar de rubenelpran


    Como compilar blender 2 5 en ubuntu para determinar errores

    Prueba con esto:
    -Descárgate una versión ya compilada que se ajuste a las características de tu equipo aquí.
    -Descomprime el archivo y ejecuta desde un terminal (abres un terminal en la carpeta dónde está el ejecutable y lo lanzas./blender).
    -Observa en el terminal los mensajes de error que te dé. Luego, vuelve a publicar el error en el foro.

    Lo más probable es que sea un problema de dependencias o que te falte alguna (s) librería (s). Con el mensaje de error puedes averiguar que librerías te faltan e instalarlas manualmente desde synaptic. Saludos.

    Ok gracias lo intentaré.


  • #8
    rubenelpran está desconectado

    Usuario Senior Avatar de rubenelpran


    Como compilar blender 2 5 en ubuntu para determinar errores

    No sé si los tiros pueden ir por ahí, pero, que versión de Python tienes instalada? (para la 2.5 necesitas Python 2.6).

    Para verlo rápidamente sólo introduce.

    Python.

    Y luego sales con Control + d.

    Bueno tengo la versión Python 2.6.5.


  • #9
    rubenelpran está desconectado

    Usuario Senior Avatar de rubenelpran


    Como compilar blender 2 5 en ubuntu para determinar errores

    Bueno intente sobre esas versiones compiladas, pero me piden y piden dependencias de más, y en eso seguí y seguí, probé como 4 pero que va, que lástima, será que espero la versión próxima estable?


  • #10
    rubenelpran está desconectado

    Usuario Senior Avatar de rubenelpran


    Como compilar blender 2 5 en ubuntu para determinar errores

    Hice esta compilación, pero no puedo abrir Blender bien, se ve feo, intente esto de aquí en el foro, pero no nada de nada y también con una versión de gráfica, pero que va nada de nada, ahora prácticamente se me ve mejor con la versión desde la web oficial, pero aún no funciona y se me queda pegado a veces. https://www.foro3d.com/f16/no-consig…0-a-86776.html.

    Código:

    Rubn@Rubn-Xubuntu:~/descargas/1372_blender25/blender25$ sudo./blender. Found bundled Python: /home/Rubn/descargas/1372_blender25/blender25/2.55/Python.
    *Bpy stats* - Tot exec: 98, tot run: 0.0158sec, average run: 0.000161sec, tot usage 0.0548%. X error of failed request: baddrawable (invalid pixmap or window parameter). Major opcode of failed request: 137 (xfre86-dri). Minor opcode of failed request: 9 (). Resource id in failed request: 0x4200002. Serial number of failed request: 406. Current serial number in output stream: 406.

    .

    Miniaturas adjuntas Miniaturas adjuntas

    -blender1.png
     

    Última edición por 3dpoder; 28-11-2011 a las 14:19 Razón: Adjuntar las imágenes al foro


  • #11
    angelsan está desconectado

    blenderniaco Avatar de angelsan


    Como compilar blender 2 5 en ubuntu para determinar errores

    Pues tiene toda la pinta de ser un problema de drivers de la gráfica. Pásate por el hilo abierto sobre Ubuntu 10.10 que ahí ya se han comentado cosas sobre ese tema: https://www.foro3d.com/f39/Ubuntu-10…tml#post780319. Saludos.


  • #12
    rubenelpran está desconectado

    Usuario Senior Avatar de rubenelpran


    Como compilar blender 2 5 en ubuntu para determinar errores

    Bueno ya solucione mi problema, lo que hice fue conseguir una tarjeta de video, y listo funcionando en Xubuntu 10.10 con Blender 2.55. Saludos.o. S.