Cura 3D no segmenta toda la pieza

Hola a todos! El problema es básicamente ese, cura no me segmenta toda la pieza. Quería probar hacer mi primer pieza para imprimir en 3D, lo que pensé que me resultaría más sencillo, pero dado mi escaso nivel en el modelado, voy a cuestas. El modelo lo hice en blender, y para probar intenté diseñar unas de las famosas macetas "Robert", que están en todos lados. En fin, cuando exporto el modelo en .stl desde blender no hay problema. Luego lo abro en cura, y en el modo "preparar" se ve completamente bien pero cuando lo segmento, al visualizarlo en la vista previa, aparecen solo algunas partes. Para no tener que explicar tanto me remito a las imágenes.
Como dato curioso comento que la primer vez que abrí el archivo funcionó la segmentación, y me daba un tiempo de unas 2 horas, pero luego cerré el programa y borré el stl para modificar unas cosas. Y ahora pasa esto, y me da un tiempo estimado de 36 minutos, porque claro, no segmenta todo. Si alguien puede ayudar, se lo agradecería muchísimo, y calmarían mi frustración con mi primer modelo fallido :no:.

Cura 3D no segmenta toda la pieza-cura.png Cura 3D no segmenta toda la pieza-cura2.png

Quería subir el .blend pero no me sube nada a pasteall.org. Si alguien sabe de otra manera lo comparto.

Gracias por haber leído. Los leo por acá si tienen algo que decir. Saludos.

Miniaturas adjuntas
Cura 3D no segmenta toda la pieza-cura.png   Cura 3D no segmenta toda la pieza-cura2.png  

Ver más sobre el tema y comentarios en el foro