[Maya] Problema agregando keyframe

  • #1
    mayatest está desconectado

    Usuario Novato


    Problema agregando keyframe

    Mi consulta es la siguiente. Quiero animar un detalle en mí personaje, y es que se levanten las cejas, hice una corta animación (desde los frames 8 al 20, teniendo tres keyframe, 8, 14 y 20, o sea, del 8 al 14 se levantan las cejas y del 14 al 20 bajan), sin embargo, intento hacer la misma animación entre los frames 115 al 125 (con tres keyframe 115, 120 y 125) y tengo problemas. El problema es que desde el keyframe 20 hasta el nuevo creado, el 115 hay una animación de las cejas que yo no he creado, simplemente creo un keyframe en el frame 115 (o en cualquier otro frame) y se crea la animación no deseada y distorsionada. Espero me puedan ayudar. Saludos.

    Última edición por mayatest; 02-09-2010 a las 18:44


  • #2
    Astu está desconectado

    Usuario Avanzado


    Problema agregando keyframe

    Según me comentas lo que tienes que hacer es copiar la última clave de tu animación, la 20, en la 115 y así en los frames que hay intermedios entre las dos claves, no debería de tener movimiento, después en la 120, subirian las cejas y volverian a bajar.

    Cuando hagas eso, fíjate que en las curvas de animación y que en el recorrido del 20 al 115, las curvas tengan los mismos parámetros y que no hagan curvas entre sí, que sean lineales.

    No sé si me he explicado bien, ya me contaras. Un saludo.


  • #3
    dsolo está desconectado

    Nivel Héroe


    Problema agregando keyframe

    El programa interpola entre esas claves, dependiendo de las curvas que estés usando, aunque tengas una clave de entrada y salida idénticas te puede pasar esto que comentas. Una de dos, o entras al Graph editor y tocas las curvas para corregir esto, o una solución bastante más antigua que pasaría por crear una clave idéntica a la del 20, en el 21 y en el 114.

    «Digresionando»


  • #4
    mayatest está desconectado

    Usuario Novato


    Problema agregando keyframe

    Agradesco mucho la respuesta de ambos, ya que las soluciones propuesta (trabajar con las curvas) me resultó. Soy nuevo usando Maya, no llevo ni un mes (estoy haciendo mi primera animación en Maya), el programa me ha gustado bastante de todos los que he probado, recientemete baje una demo de Cinema 4D y se ve bastante intuitivo, pero me he acostumbrado con Maya en tan poco tiempo. Pensé que Poser sería la solución a mi deseo de animar (nada de modelado) en 3d, pero era muy pesado y no contaba con muchos y buenos recursos para animar. Aunque la interfaz de Blender ha cambiado para ser más vistosa, nunca me he acostumbrado a él. En cuanto a 3ds Max (que entiendo es el más usado), nunca he bajado tan siquiera una versión de demostración del programa. Cuando pueda le mostraré un video corto del ejemplo, no lo he hecho por los problemas para entrar a www.foro3d.com, donde la web no me carga, por ello he aprovechado que pude entrar hoy. Lo que hice fue entrar a Graph editor y seleccionar las curvas y moverlas al centro, que no quede curvas sino una línea recta, y así me funcionó, no sé si era el método, pero resultó. Sin más, muchas gracias por sus respuesta. Un saludo.

    Última edición por mayatest; 08-09-2010 a las 17:08


  • #5
    mac3d está desconectado

    Usuario completo Avatar de mac3d


    Problema agregando keyframe

    Para solucionar el problema rápidamente te vas al Graph editor, seleccione todos los keys y pulsas flat tangents, esto lo que hace es frenar los extremos que forman la curva (keys) y consigues que de alguna forma no aparezcan animaciones creadas por las interpolaciones. (te lo explico en plan que se entienda, pero el tema de curvas de animación tiene su historia). Un saludo.

    Esperando noticias de Autodesk.