Pixel bleeding problemas con bordes en las texturas

  • #1
    Kitsune está desconectado

    Usuario Nuevo


    pixel bleeding problemas con bordes en las texturas

    Buenas tengo un problema que no sé cómo solucionar. El caso es que cuando texturizo unos modelos y hago render to texture, max deja unos seams muy feos, se ven líneas negras en las juntas de las texturas. He leído que eso se soluciona con píxel bleding (algo que polybost y 3d Paint tienen), pero aquí yo no estoy pintando la textura, si no que la saco de otro modelo con más resolución usando projection. Me gustaría saber si hay manera de hacer eso en 3dsMax ya que pintar los bordes manualmente, no es precisamente cosa fácil. Quizás haya algún programa o plugin para Photoshop que en base a la transparencia de la imagen, repita los últimos píxeles asta hacer bleding o quizás max tenga esa opción (he revisado el panel de rt asta la saciedad y nada).

    También me gustaría saber cómo eliminar el a del render to texture. Scanline suaviza los bordes por defecto, y eso no ayuda precisamente a corregir esos bordes. Por el contrario, FinalRender no aplica a y deja unos bordes bastante buenos sin esas líneas. Pero claro, si redimensionas la textura, ese borde se vuelve a suavizar y vuelven a aparecer los problemas. Cabe mencionar que no puedo cambiar las UVW de las texturas para hacerlas algo más grandes y así evitar los bordes ya que se trata de texturas para un juego y los modelos son los que son, no se pueden cambiar. Os dejo un ejemplo de cómo lo hace Scanline y FinalRender. A ver si me podéis echar una mano para desactivar el a en Scanline y que quede cómo FinalRender. Por cierto, probé a desactivar a, global sampler y asta el filtrado de texturas, pero nada, sigue igual :@. Cualquier ayuda, comentario o técnica para resolver eso será bienvenida, desde ya muchas gracias.

    Posdata: uso 3dsMax 2009.

    Miniaturas adjuntas Miniaturas adjuntas

    Pixel bleeding problemas con bordes en las texturas-uvexample.jpg
     

    Última edición por 3dpoder; 09-03-2012 a las 12:23


  • #2
    Nessito está desconectado

    Usuario Legendario


    pixel bleeding problemas con bordes en las texturas

    No sé qué decirte, si en Scanline quitas el antialias, no hace ni antialias, ni filtrado, ni nada de nada. Prueba una opción de las preferencias que es dont antialias against background, en rendering, para que no haga antialias contra el fondo, pero si el resto. Es lo único que se me ocurre, como no pongas algún ejemplo del problema, (en lo que has puesto no veo el problema de bleding que comentas, solo del a).

    Aquel que pregunta, es tonto un rato. Aquel que no pregunta, es tonto toda la vida.


  • #3
    Kitsune está desconectado

    Usuario Nuevo


    pixel bleeding problemas con bordes en las texturas

    El problema es que, aunque quite el antialias, todo sigue con antialias. Lo único que si se puede quitar es el filtrado de texturas, eso sí. Bueno el problema es bien simple, usando la textura de 2048 píxeles del baked, con la de la izquierda de Scanline tendría líneas blancas entre los seams/bordes en el modelo porque digamos que la textura está demasiado ajustada al UV map. Mientras que con la de FinalRender, no solo no tiene a si no que además eso hace que tenga más de un píxel de ancho fuera del UV map y así no tengo líneas blancas en los seam. Pero claro, las texturas las hago en alta calidad para después redimensionar, ya que necesito varios tamaños, y en cuanto la redimensiono, vuelve a tener efecto similar a a. Claro está, que si uso un fondo gris en vez de blanco, todo queda más disimulado, pero esa tampoco es la cuestión. Por ejemplo, imagina que haces un modelo humano y la parte de la camiseta, en el UVW la divides en dos partes para texturizar, frontal y trasera. Ahora coges otro modelo de alta calidad y haces un bake para sacar ya sea el Normal Map como la textura en si. Asta ahí todo bien. El problema viene cuando aplicas esa textura y en los bordes entre la parte trasera y delantera tienes unas líneas grises (ya que toda la ropa no es de un solo color pues los defectos son varios). El bleding lo que hace es repetir el último píxel al borde de las diferentes partes de un UV map para que eso no pase. Digamos que es como un margen adicional para evitar imperfecciones. Y el problema precisamente es que no consigo desactivar el a para Scanline, aunque desactive todo, cambie de a, haga lo que haga, no afecta nada al a usado para el RT. En el rt hay una opción llamada padding que supuestamente es para eso, pero por más que cambio el valor de 0 a 64 que es el máximo, nada cambia, siempre está todo igual. La única manera que he encontrado es usar FinalRender, el cual aún activando a no te filtra el rt (los bordes claro, el resto si). Intentare esa opción que dices a ver.

    La verdad es que es un problema muy común, más de lo que parece, lo que pasa que la mayoría hacen las texturas encima manualmente, por lo que tienes control sobre ese margen o borde alrededor de los elementos del UV map. Donde si la gente tiene más problemas es al sacar normals maps, ya que ajustarlos manualmente seria otro cantar. Pero yo modele ropa en alta definición usando Mudbox y quiero poner esa textura con sombras en un modelo Low poly. Hacerlo a mano será tedioso, aparte de que no quedaría igual ni de lejos. Y por otro lado, es algo que pasa con absolutamente todo lo que se modele, así que, creo útil resolver ese problema de una vez y de una forma eficaz. Es raro que el propio max no traiga esa opción por defecto o algo así, o que no haya plugins o scripts para ello. O quizás lo trae, pero yo no lo sé, por eso pregunto. Saludos y gracias por contestar tan rápido. Probare esa opción y te comentaré a ver qué tal. Intentare publicar unas imágenes con esas líneas horribles, pero estoy seguro que ya sabes a que me refiero.


  • #4
    Nessito está desconectado

    Usuario Legendario


    pixel bleeding problemas con bordes en las texturas

    Y el padding no te sirve. Me parece que es justo eso lo que quieres. Podrías poner una captura de una parte del unwrap donde te da problemas? Solo una parte y solo el unwrap.

    Última edición por Nessito; 30-08-2010 a las 10:38

    Aquel que pregunta, es tonto un rato. Aquel que no pregunta, es tonto toda la vida.


  • #5
    Kitsune está desconectado

    Usuario Nuevo


    pixel bleeding problemas con bordes en las texturas

    Vale culpa mía =_=. Estuve haciendo varios rt, manipulando el padding y la textura era la misma, no cambiaba. Active para que en el viewport se viese la textura directamente al hacer el rt (ya sabes, marcando original o baked donde dice view y render, vamos que cambie el Shell material). Y me di cuenta, que, aunque mi textura no cambiaba un solo píxel en la ventana del rt, si que lo hacía en el vieport, pues con padding 0 los bordes eran inmensos. Al final me di cuenta que la textura que se renderiza no cambia, pero en cambio la que se guarda directamente si que cambia y le sale padding hasta por las orejas =______=u. Claro, yo siempre usaba el panel de renderizado y le daba a guardar y así escogia el formato que más me gustase. Me acostumbre a hacerlo así desde que hace tiempo Vray me guardaba las texturas en negro mientras en la ventana de render se veían bien. Bueno, al menos se solucionó. Muchas gracias, quien iba a pensar que la textura seria diferente del panel a la que se guarda. >_>.