Por que me pasa esto

  • #1
    GRG D.S. está desconectado

    Usuario Novato


    Por qué me pasa esto?

    Hola, no tengo mucha expriencia con 3dsm, y me surgen dudas como en el siguiente caso, tengo dos objetos, los convierto en uno con attach y empiezo a unirlos.

    En el viewport se ve como la imagen que adjunto. ¿por qué esa superficie se queda negra? ¿por qué no incide la luz de la misma forma en todo el objeto? Parte del objeto verde se ilumina y parte se queda negro, por que pasa eso? Agradecería que alguien me explicara que hago mal. Saludos.

    Miniaturas adjuntas Miniaturas adjuntas

    Por que me pasa esto-9367tb.jpg
     

    Última edición por 3dpoder; 15-03-2012 a las 07:04


  • #2
    akull está desconectado

    3dzero vfx


    Por qué me pasa esto?

    Poligon flip, (es por las normales de los polígonos. Las tienes invertidas).


  • #3
    dlgmax está desconectado

    Gunsmith Avatar de dlgmax


    Por qué me pasa esto?

    Buenas como te comentan es por las normales aparte del método que te han dado, también podrías hacer lo siguiente antes de atachar seleccione el objeto que ves que se queda oscuro vas a la persiana de la derecha, en modificadores y buscas un que pone normal. Cuando lo selecciones veras que tienes dos opciones voltear y unificar en tu caso deberías voltear y ya está contraes el catálogo en poly edit y vuelves a atachar.

    Aunque lo veas más complicado que el otro sistema es igual de simple, pero con un modificador aparte con lo que, si no contraes el catálogo y sigues trabajando siempre es posible desacerlo o retocarlo por cualquier motivo, de la otra manera si cometiste algún fallo o te quedo algún polígono por ahí perdido la malla te estará dando fallos y después no podría volver atrás y al final la solución no sería la mejor.

    Te lo digo por experiencia ya que, al unir objetos muchas veces sin querer quitas o dejas polígonos que después de modelar y modelar al final quieres unir algo o cortar o que se yo y después te dice la malla que no que no hay tu tía y es un policono pequeño que se quedó por medio de la malla el que no deja hacer estas operación.

    Ya te digo que los dos métodos sopn válidos, pero dependiendo de la complejidad me decantaría por uno o por otro. Saludos.


  • #4
    GRG D.S. está desconectado

    Usuario Novato


    Por qué me pasa esto?

    Poligon flip, (es por las normales de los polígonos. Las tienes invertidas).

    Buenas como te comentan es por las normales aparte del método que te han dado, también podrías hacer lo siguiente antes de atachar seleccione el objeto que ves que se queda oscuro vas a la persiana de la derecha, en modificadores y buscas un que pone normal. Cuando lo selecciones veras que tienes dos opciones voltear y unificar en tu caso deberías voltear y ya está contraes el catálogo en poly edit y vuelves a atachar.

    Aunque lo veas más complicado que el otro sistema es igual de simple, pero con un modificador aparte con lo que, si no contraes el catálogo y sigues trabajando siempre es posible desacerlo o retocarlo por cualquier motivo, de la otra manera si cometiste algún fallo o te quedo algún polígono por ahí perdido la malla te estará dando fallos y después no podría volver atrás y al final la solución no sería la mejor.

    Te lo digo por experiencia ya que, al unir objetos muchas veces sin querer quitas o dejas polígonos que después de modelar y modelar al final quieres unir algo o cortar o que se yo y después te dice la malla que no que no hay tu tía y es un policono pequeño que se quedó por medio de la malla el que no deja hacer estas operación.

    Ya te digo que los dos métodos sopn válidos, pero dependiendo de la complejidad me decantaría por uno o por otro. Saludos.

    Bua perfecto, muchas gracias a los dos.

    He usado el método de normal, pero me apunto el otro también por si acaso. Gracias. Saludos.