Sorteo un jamón

Hola, el problema que tengo no sé si es de hardware, software o sistema operativo o si soy yo el problema. Realmente no es un problema, sino una decepción.

Trabajo, como muchos miembros de este foro, en la creación de imágenes de síntesis, y al margen de si las imágenes resultantes son bonitas o no (no es este el objeto de mi cuestión) si que las entrego siempre a 4000×3000, como os podéis imaginar. Lo cual me lleva unas 12 horas de render por ordenador(tengo 2 iguales), en el mejor de los casos. Est0s ordenadores en valoración de 0-10 les doy un 6 (al fin y al cabo, ellos me dan de comer a mí): tienen 3 Gb de Ram, GeForce 254 Mb y 3200 el procesador AMD. No hace falta que me extienda más. El caso es que vivía tranquilo con los gemelos y con esos tiempos de render, hasta que me entró más trabajo y esas 12 horas de render las tenía que reducir, para hacer más en menos tiempo. Yme dije, pero que cojones invierte en algo más potente, toda inversión es crecimiento (I+D+i) y compre los siguientes componentes:
Disco duro SATA I 300 Gb.

Placa base: 939 ATX.AMD Asus A8N-SLI premium.
4 Gb Ram.

Tarjeta gráfica: PCI Express Nvidia FX1400 128 Mb Quadro Pny.

Microprocesador: AMD Athlon 64 939 3500+ box.

La verdead es que este micro lo compre porque los Dual Core de AMD estaban en stock (en agosto), para salir del paso vaya. Ahora he encargado este procesador: microprocesador AMD Athlon 64 939 x2 4800+ box, que me lo traearan en breve. Bueno, todo parece sencillo y lógico, vamos que hay armonía. El caso es que con el PC descrito el tiempo de render ha disminuido sí, pero un 10%, yo estoy convencido de que, aparte del micro, hay algo de configuración. Vaya, se me olvidaba, todo está bajo Windows XP 64.

Bueno, como reza en el título, sorteo un jamón entre los que me ayuden. Y por supuesto, perdonad mi ignorancia.